{"answers":{"affected":"2 open source packages ship an affected version, including com.openshift.jenkins:openshift-pipeline. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2167 in the wild and no public exploit code.","fix":"Upgrade com.openshift.jenkins:openshift-pipeline to 1.0.57 or later.","what":"CVE-2020-2167 is a high-severity unsafe deserialization vulnerability in Jenkins OpenShift Pipeline Plugin, published on 25 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2167 and fix it if it is affected.\n\nWhat it is: CVE-2020-2167 is a high-severity unsafe deserialization vulnerability in Jenkins OpenShift Pipeline Plugin, published on 25 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2167 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.openshift.jenkins:openshift-pipeline (Maven): affected all versions; fixed in 1.0.57\n- com.openshift.jenkins:openshift-pipeline (Maven): affected all versions; fixed in 1.0.57\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2167/ (Markdown: https://insights.sbomify.com/CVE-2020-2167/index.md)","id":"CVE-2020-2167","markdown":"https://insights.sbomify.com/CVE-2020-2167/index.md","name":"CVE-2020-2167","record":{"aliases":["GHSA-264w-xrr7-6qqg","RHSA-2020:0964"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins OpenShift Plugin","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution via unsafe YAML deserialization in the Jenkins OpenShift Pipeline Plugin.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"openshift_pipeline","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Jenkins OpenShift Pipeline Plugin 1.0.56 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.","ecosystems":["Maven","Red Hat:openshift:3.11::el7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RCE vulnerability in Jenkins OpenShift Pipeline Plugin","id":"CVE-2020-2167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":4,"n_references":2,"next":{"headline":"RCE vulnerability in Jenkins Azure Container Service Plugin","id":"CVE-2020-2168"},"packages":[{"ecosystem":"Maven","fixed":["1.0.57"],"introduced":["0"],"last_affected":[],"package":"com.openshift.jenkins:openshift-pipeline","purl":null,"source":"GHSA-264w-xrr7-6qqg"},{"ecosystem":"Maven","fixed":["1.0.57"],"introduced":["0"],"last_affected":[],"package":"com.openshift.jenkins:openshift-pipeline","purl":"pkg:maven/com.openshift.jenkins/openshift-pipeline","source":"GHSA-264w-xrr7-6qqg"},{"ecosystem":"Red Hat:openshift:3.11::el7","fixed":["0:2.204.2.1585048146-1.el7"],"introduced":["0"],"last_affected":[],"package":"jenkins","purl":"pkg:rpm/redhat/jenkins","source":"RHSA-2020:0964"},{"ecosystem":"Red Hat:openshift:3.11::el7","fixed":["0:3.11.1585050035-1.el7"],"introduced":["0"],"last_affected":[],"package":"jenkins-2-plugins","purl":"pkg:rpm/redhat/jenkins-2-plugins","source":"RHSA-2020:0964"}],"prev":{"headline":"RCE vulnerability in Jenkins Pipeline: AWS Steps Plugin","id":"CVE-2020-2166"},"products":["Jenkins OpenShift Pipeline Plugin"],"published":"2020-03-25","related":[{"cvss_score":4.3,"headline":"Jenkins OpenShift Pipeline Plugin stores authorization tokens unencrypted in job config.xml files","id":"CVE-2025-64143","kev_date_added":null,"published":"2025-10-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can achieve remote code execution via unsafe YAML deserialization in the Jenkins OpenShift Pipeline Plugin.","url":"https://insights.sbomify.com/CVE-2020-2167/"}