# CVE-2020-2167: RCE vulnerability in Jenkins OpenShift Pipeline Plugin

> Attackers can achieve remote code execution via unsafe YAML deserialization in the Jenkins OpenShift Pipeline Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-264w-xrr7-6qqg, RHSA-2020:0964

## What is CVE-2020-2167?

CVE-2020-2167 is a high-severity unsafe deserialization vulnerability in Jenkins OpenShift Pipeline Plugin, published on 25 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins OpenShift Pipeline Plugin 1.0.56 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-2167?

2 open source packages ship an affected version, including com.openshift.jenkins:openshift-pipeline. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.openshift.jenkins:openshift-pipeline` | Maven | All versions | 1.0.57 |
| `com.openshift.jenkins:openshift-pipeline` | Maven | All versions | 1.0.57 |
| `jenkins` | Red Hat:openshift:3.11::el7 | All versions | 0:2.204.2.1585048146-1.el7 |
| `jenkins-2-plugins` | Red Hat:openshift:3.11::el7 | All versions | 0:3.11.1585050035-1.el7 |

Products: Jenkins Openshift Pipeline.

## How do I fix CVE-2020-2167?

Upgrade com.openshift.jenkins:openshift-pipeline to 1.0.57 or later.

## Is CVE-2020-2167 being exploited?

There is no known exploitation of CVE-2020-2167 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins OpenShift Pipeline Plugin

- [CVE-2025-64143](https://insights.sbomify.com/CVE-2025-64143/): Jenkins OpenShift Pipeline Plugin stores authorization tokens unencrypted in job config.xml files (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2167 and fix it if it is affected.

What it is: CVE-2020-2167 is a high-severity unsafe deserialization vulnerability in Jenkins OpenShift Pipeline Plugin, published on 25 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2167 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.openshift.jenkins:openshift-pipeline (Maven): affected all versions; fixed in 1.0.57
- com.openshift.jenkins:openshift-pipeline (Maven): affected all versions; fixed in 1.0.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2167/ (Markdown: https://insights.sbomify.com/CVE-2020-2167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2167
- OSV: https://osv.dev/vulnerability/CVE-2020-2167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2167/
Summaries are generated and may contain mistakes; the official description above is the record.
