{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:code-coverage-api. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2172 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:code-coverage-api to 1.1.5 or later.","what":"CVE-2020-2172 is a medium-severity vulnerability in Jenkins Code Coverage API Plugin, published on 7 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2172 and fix it if it is affected.\n\nWhat it is: CVE-2020-2172 is a medium-severity vulnerability in Jenkins Code Coverage API Plugin, published on 7 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2172 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.1.5\n- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2172/ (Markdown: https://insights.sbomify.com/CVE-2020-2172/index.md)","id":"CVE-2020-2172","markdown":"https://insights.sbomify.com/CVE-2020-2172/index.md","name":"CVE-2020-2172","record":{"aliases":["GHSA-cmgm-q8hf-p7jc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Code Coverage Plugin","requires_auth":"low_privilege","summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins Code Coverage API Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"code_coverage_api","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-776","name":"Improper Restriction of Recursive Entity References in DTDs"}],"description":"Jenkins Code Coverage API Plugin 1.1.4 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins Code Coverage API Plugin","id":"CVE-2020-2172","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"XSS vulnerability in Jenkins Gatling Plugin","id":"CVE-2020-2173"},"packages":[{"ecosystem":"Maven","fixed":["1.1.5"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:code-coverage-api","purl":null,"source":"GHSA-cmgm-q8hf-p7jc"},{"ecosystem":"Maven","fixed":["1.1.5"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:code-coverage-api","purl":"pkg:maven/io.jenkins.plugins/code-coverage-api","source":"GHSA-cmgm-q8hf-p7jc"}],"prev":{"headline":"XXE vulnerability in Jenkins RapidDeploy Plugin","id":"CVE-2020-2171"},"products":["Jenkins Code Coverage API Plugin"],"published":"2020-04-07","related":[{"cvss_score":8.8,"headline":"RCE vulnerability in Jenkins Code Coverage API Plugin","id":"CVE-2021-21677","kev_date_added":null,"published":"2021-08-31"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Code Coverage API Plugin","id":"CVE-2020-2106","kev_date_added":null,"published":"2020-01-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins Code Coverage API Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2020-2172/"}