# CVE-2020-2172: XXE vulnerability in Jenkins Code Coverage API Plugin

> An attacker can exploit XML external entity vulnerabilities in the Jenkins Code Coverage API Plugin to read sensitive files or cause denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cmgm-q8hf-p7jc

## What is CVE-2020-2172?

CVE-2020-2172 is a medium-severity vulnerability in Jenkins Code Coverage API Plugin, published on 7 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Code Coverage API Plugin 1.1.4 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2020-2172?

2 open source packages ship an affected version, including io.jenkins.plugins:code-coverage-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:code-coverage-api` | Maven | All versions | 1.1.5 |
| `io.jenkins.plugins:code-coverage-api` | Maven | All versions | 1.1.5 |

Products: Jenkins Code Coverage Api.

## How do I fix CVE-2020-2172?

Upgrade io.jenkins.plugins:code-coverage-api to 1.1.5 or later.

## Is CVE-2020-2172 being exploited?

There is no known exploitation of CVE-2020-2172 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Code Coverage API Plugin

- [CVE-2021-21677](https://insights.sbomify.com/CVE-2021-21677/): RCE vulnerability in Jenkins Code Coverage API Plugin (high 8.8)
- [CVE-2020-2106](https://insights.sbomify.com/CVE-2020-2106/): Stored XSS vulnerability in Code Coverage API Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2172 and fix it if it is affected.

What it is: CVE-2020-2172 is a medium-severity vulnerability in Jenkins Code Coverage API Plugin, published on 7 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2172 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.1.5
- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2172/ (Markdown: https://insights.sbomify.com/CVE-2020-2172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2172
- OSV: https://osv.dev/vulnerability/CVE-2020-2172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2172/
Summaries are generated and may contain mistakes; the official description above is the record.
