# CVE-2020-2174: Reflected XSS vulnerability in Jenkins AWSEB Deployment Plugin

> Reflected cross-site scripting in Jenkins AWSEB Deployment Plugin allows attackers to execute arbitrary scripts in victim browsers via form validation output.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f82v-pg74-6686

## What is CVE-2020-2174?

CVE-2020-2174 is a medium-severity cross-site scripting vulnerability in Jenkins AWSEB Deployment Plugin, published on 7 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins AWSEB Deployment Plugin 0.3.19 and earlier does not escape various values printed as part of form validation output, resulting in a reflected cross-site scripting vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2174?

2 open source packages ship an affected version, including br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin` | Maven | All versions | 0.3.20 |
| `br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin` | Maven | All versions | 0.3.20 |

Products: Jenkins Awseb Deployment.

## How do I fix CVE-2020-2174?

Upgrade br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin to 0.3.20 or later.

## Is CVE-2020-2174 being exploited?

There is no known exploitation of CVE-2020-2174 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2174 and fix it if it is affected.

What it is: CVE-2020-2174 is a medium-severity cross-site scripting vulnerability in Jenkins AWSEB Deployment Plugin, published on 7 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2174 in the wild and no public exploit code.

Affected packages and fixed versions:
- br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (Maven): affected all versions; fixed in 0.3.20
- br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (Maven): affected all versions; fixed in 0.3.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2174/ (Markdown: https://insights.sbomify.com/CVE-2020-2174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2174
- OSV: https://osv.dev/vulnerability/CVE-2020-2174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2174/
Summaries are generated and may contain mistakes; the official description above is the record.
