{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:aws-sam. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2180 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:aws-sam to 1.2.3 or later.","what":"CVE-2020-2180 is a high-severity unsafe deserialization vulnerability in Jenkins AWS SAM Plugin, published on 16 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2180 and fix it if it is affected.\n\nWhat it is: CVE-2020-2180 is a high-severity unsafe deserialization vulnerability in Jenkins AWS SAM Plugin, published on 16 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2180 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:aws-sam (Maven): affected all versions; fixed in 1.2.3\n- io.jenkins.plugins:aws-sam (Maven): affected all versions; fixed in 1.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2180/ (Markdown: https://insights.sbomify.com/CVE-2020-2180/index.md)","id":"CVE-2020-2180","markdown":"https://insights.sbomify.com/CVE-2020-2180/index.md","name":"CVE-2020-2180","record":{"aliases":["GHSA-qrm8-cw73-r9w8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins AWS SAM Plugin","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code via unsafe YAML deserialization in the Jenkins AWS SAM Plugin.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"amazon_web_services_serverless_application_model","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Jenkins AWS SAM Plugin 1.2.2 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RCE vulnerability in Jenkins AWS SAM Plugin","id":"CVE-2020-2180","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Secrets are not masked by Jenkins Credentials Binding Plugin in builds without build steps","id":"CVE-2020-2181"},"packages":[{"ecosystem":"Maven","fixed":["1.2.3"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:aws-sam","purl":null,"source":"GHSA-qrm8-cw73-r9w8"},{"ecosystem":"Maven","fixed":["1.2.3"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:aws-sam","purl":"pkg:maven/io.jenkins.plugins/aws-sam","source":"GHSA-qrm8-cw73-r9w8"}],"prev":{"headline":"RCE vulnerability in Jenkins Yaml Axis Plugin","id":"CVE-2020-2179"},"products":["Jenkins AWS SAM Plugin"],"published":"2020-04-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Remote attackers can execute arbitrary code via unsafe YAML deserialization in the Jenkins AWS SAM Plugin.","url":"https://insights.sbomify.com/CVE-2020-2180/"}