{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2190 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:script-security to 1.73 or later.","what":"CVE-2020-2190 is a medium-severity cross-site scripting vulnerability in Jenkins Script Security Plugin, published on 3 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2190 and fix it if it is affected.\n\nWhat it is: CVE-2020-2190 is a medium-severity cross-site scripting vulnerability in Jenkins Script Security Plugin, published on 3 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2190 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.73\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.73\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2190/ (Markdown: https://insights.sbomify.com/CVE-2020-2190/index.md)","id":"CVE-2020-2190","markdown":"https://insights.sbomify.com/CVE-2020-2190/index.md","name":"CVE-2020-2190","record":{"aliases":["GHSA-q87g-7mp5-765q","RHSA-2020:3207"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Script Security Plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Script Security Plugin allows attackers to execute arbitrary scripts in the context of other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"script_security","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Script Security Plugin 1.72 and earlier does not correctly escape pending or approved classpath entries on the In-process Script Approval page, resulting in a stored cross-site scripting vulnerability.","ecosystems":["Maven","Red Hat:openshift:4.5::el7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation in Jenkins Script Security Plugin","id":"CVE-2020-2190","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":3,"n_references":2,"next":{"headline":"Improper permission checks in Jenkins Swarm Plugin","id":"CVE-2020-2191"},"packages":[{"ecosystem":"Maven","fixed":["1.73"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":null,"source":"GHSA-q87g-7mp5-765q"},{"ecosystem":"Maven","fixed":["1.73"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":"pkg:maven/org.jenkins-ci.plugins/script-security","source":"GHSA-q87g-7mp5-765q"},{"ecosystem":"Red Hat:openshift:4.5::el7","fixed":["0:4.5.1595405982-1.el7"],"introduced":["0"],"last_affected":[],"package":"jenkins-2-plugins","purl":"pkg:rpm/redhat/jenkins-2-plugins","source":"RHSA-2020:3207"}],"prev":{"headline":"RCE vulnerability in SCM Filter Jervis Plugin","id":"CVE-2020-2189"},"products":["Jenkins Script Security Plugin"],"published":"2020-06-03","related":[{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin Sandbox Bypass","id":"CVE-2019-1003029","kev_date_added":"2022-04-25","published":"2019-03-08"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43401","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin sandbox bypass vulnerability","id":"CVE-2022-43403","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43404","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerability in Jenkins Script Security Plugin","id":"CVE-2020-2279","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":9.9,"headline":"Improper Control of Generation of Code in Jenkins Script Security Plugin","id":"CVE-2019-10431","kev_date_added":null,"published":"2019-10-01"},{"cvss_score":9.8,"headline":"Jenkins Script Security Plugin has sandbox bypass vulnerability involving crafted constructor bodies","id":"CVE-2024-34144","kev_date_added":null,"published":"2024-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Script Security Plugin allows attackers to execute arbitrary scripts in the context of other users.","url":"https://insights.sbomify.com/CVE-2020-2190/"}