# CVE-2020-2190: Improper Neutralization of Input During Web Page Generation in Jenkins Script Security Plugin

> Stored XSS in Jenkins Script Security Plugin allows attackers to execute arbitrary scripts in the context of other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q87g-7mp5-765q, RHSA-2020:3207

## What is CVE-2020-2190?

CVE-2020-2190 is a medium-severity cross-site scripting vulnerability in Jenkins Script Security Plugin, published on 3 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Script Security Plugin 1.72 and earlier does not correctly escape pending or approved classpath entries on the In-process Script Approval page, resulting in a stored cross-site scripting vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2190?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.73 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.73 |
| `jenkins-2-plugins` | Red Hat:openshift:4.5::el7 | All versions | 0:4.5.1595405982-1.el7 |

Products: Jenkins Script Security.

## How do I fix CVE-2020-2190?

Upgrade org.jenkins-ci.plugins:script-security to 1.73 or later.

## Is CVE-2020-2190 being exploited?

There is no known exploitation of CVE-2020-2190 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Script Security Plugin

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2190 and fix it if it is affected.

What it is: CVE-2020-2190 is a medium-severity cross-site scripting vulnerability in Jenkins Script Security Plugin, published on 3 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2190 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.73
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.73

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2190/ (Markdown: https://insights.sbomify.com/CVE-2020-2190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2190
- OSV: https://osv.dev/vulnerability/CVE-2020-2190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2190/
Summaries are generated and may contain mistakes; the official description above is the record.
