# CVE-2020-2191: Improper permission checks in Jenkins Swarm Plugin

> Attackers can add or remove agent labels via API endpoints without proper permission checks, potentially disrupting Jenkins build operations.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-j852-mp82-wv2g

## What is CVE-2020-2191?

CVE-2020-2191 is a medium-severity missing authorization vulnerability in Jenkins Self-Organizing Swarm Plug-in Modules Plugin, published on 3 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Self-Organizing Swarm Plug-in Modules Plugin 3.20 and earlier does not check permissions on API endpoints that allow adding and removing agent labels.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2020-2191?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:swarm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:swarm` | Maven | All versions | 3.21 |
| `org.jenkins-ci.plugins:swarm` | Maven | All versions | 3.21 |

Products: Jenkins Self-Organizing Swarm Modules.

## How do I fix CVE-2020-2191?

Upgrade org.jenkins-ci.plugins:swarm to 3.21 or later.

## Is CVE-2020-2191 being exploited?

There is no known exploitation of CVE-2020-2191 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Self-Organizing Swarm Plug-in Modules Plugin

- [CVE-2019-10309](https://insights.sbomify.com/CVE-2019-10309/): Jenkins Self-Organizing Swarm Plug-in Modules Plugin XXE vulnerability via UDP broadcast response (critical 9.3)
- [CVE-2020-2192](https://insights.sbomify.com/CVE-2020-2192/): CSRF vulnerability in Jenkins Swarm Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2191 and fix it if it is affected.

What it is: CVE-2020-2191 is a medium-severity missing authorization vulnerability in Jenkins Self-Organizing Swarm Plug-in Modules Plugin, published on 3 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2191 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:swarm (Maven): affected all versions; fixed in 3.21
- org.jenkins-ci.plugins:swarm (Maven): affected all versions; fixed in 3.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2191/ (Markdown: https://insights.sbomify.com/CVE-2020-2191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2191
- OSV: https://osv.dev/vulnerability/CVE-2020-2191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2191/
Summaries are generated and may contain mistakes; the official description above is the record.
