# CVE-2020-2192: CSRF vulnerability in Jenkins Swarm Plugin

> Attackers can force users to add or remove agent labels in Jenkins Swarm Plugin via cross-site request forgery.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c264-8834-ppj2

## What is CVE-2020-2192?

CVE-2020-2192 is a medium-severity vulnerability in Jenkins Self-Organizing Swarm Plug-in Modules Plugin, published on 3 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability in Jenkins Self-Organizing Swarm Plug-in Modules Plugin 3.20 and earlier allows attackers to add or remove agent labels.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-2192?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:swarm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:swarm` | Maven | All versions | 3.21 |
| `org.jenkins-ci.plugins:swarm` | Maven | All versions | 3.21 |

Products: Jenkins Self-Organizing Swarm Modules.

## How do I fix CVE-2020-2192?

Upgrade org.jenkins-ci.plugins:swarm to 3.21 or later.

## Is CVE-2020-2192 being exploited?

There is no known exploitation of CVE-2020-2192 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Self-Organizing Swarm Plug-in Modules Plugin

- [CVE-2019-10309](https://insights.sbomify.com/CVE-2019-10309/): Jenkins Self-Organizing Swarm Plug-in Modules Plugin XXE vulnerability via UDP broadcast response (critical 9.3)
- [CVE-2020-2191](https://insights.sbomify.com/CVE-2020-2191/): Improper permission checks in Jenkins Swarm Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2192 and fix it if it is affected.

What it is: CVE-2020-2192 is a medium-severity vulnerability in Jenkins Self-Organizing Swarm Plug-in Modules Plugin, published on 3 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2192 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:swarm (Maven): affected all versions; fixed in 3.21
- org.jenkins-ci.plugins:swarm (Maven): affected all versions; fixed in 3.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2192/ (Markdown: https://insights.sbomify.com/CVE-2020-2192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2192
- OSV: https://osv.dev/vulnerability/CVE-2020-2192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2192/
Summaries are generated and may contain mistakes; the official description above is the record.
