# CVE-2020-2204: Missing permission checks in Jenkins Fortify on Demand Plugin

> Attackers with read access can connect to Fortify endpoints using arbitrary credentials, bypassing intended permission checks.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fhmf-xf2q-4m8p

## What is CVE-2020-2204?

CVE-2020-2204 is a medium-severity missing authorization vulnerability in Jenkins Fortify on Demand Plugin, published on 2 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers with Overall/Read permission to connect to the globally configured Fortify on Demand endpoint using attacker-specified credentials IDs.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2020-2204?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:fortify-on-demand-uploader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:fortify-on-demand-uploader` | Maven | All versions | 6.0.1 |
| `org.jenkins-ci.plugins:fortify-on-demand-uploader` | Maven | All versions | 6.0.1 |

Products: Jenkins Fortify on Demand.

## How do I fix CVE-2020-2204?

Upgrade org.jenkins-ci.plugins:fortify-on-demand-uploader to 6.0.1 or later.

## Is CVE-2020-2204 being exploited?

There is no known exploitation of CVE-2020-2204 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Fortify on Demand Plugin

- [CVE-2019-10449](https://insights.sbomify.com/CVE-2019-10449/): Jenkins Fortify on Demand Plugin stores credentials in plain text (high 8.8)
- [CVE-2020-2202](https://insights.sbomify.com/CVE-2020-2202/): Users with Overall/Read access could enumerate credentials IDs in Jenkins Fortify on Demand Plugin (medium 4.3)
- [CVE-2020-2203](https://insights.sbomify.com/CVE-2020-2203/): CSRF vulnerability in Jenkins Fortify on Demand Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2204 and fix it if it is affected.

What it is: CVE-2020-2204 is a medium-severity missing authorization vulnerability in Jenkins Fortify on Demand Plugin, published on 2 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2204 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:fortify-on-demand-uploader (Maven): affected all versions; fixed in 6.0.1
- org.jenkins-ci.plugins:fortify-on-demand-uploader (Maven): affected all versions; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2204/ (Markdown: https://insights.sbomify.com/CVE-2020-2204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2204
- OSV: https://osv.dev/vulnerability/CVE-2020-2204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2204/
Summaries are generated and may contain mistakes; the official description above is the record.
