# CVE-2020-2205: Stored XSS vulnerability in Jenkins VncRecorder Plugin

> Stored XSS in Jenkins VncRecorder Plugin allows administrators to inject scripts via tool path, potentially leading to code execution or account takeover.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vqp8-h53h-3jfh

## What is CVE-2020-2205?

CVE-2020-2205 is a medium-severity cross-site scripting vulnerability in Jenkins VncRecorder Plugin, published on 2 Jul 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Jenkins VncRecorder Plugin 1.25 and earlier does not escape a tool path in the `checkVncServ` form validation endpoint, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by Jenkins administrators.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2205?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:vncrecorder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:vncrecorder` | Maven | All versions | 1.35 |
| `org.jenkins-ci.plugins:vncrecorder` | Maven | All versions | 1.35 |

Products: Jenkins Vncrecorder.

## How do I fix CVE-2020-2205?

Upgrade org.jenkins-ci.plugins:vncrecorder to 1.35 or later.

## Is CVE-2020-2205 being exploited?

There is no known exploitation of CVE-2020-2205 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins VncRecorder Plugin

- [CVE-2020-2206](https://insights.sbomify.com/CVE-2020-2206/): Reflected XSS vulnerability in Jenkins VncRecorder Plugin (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2205 and fix it if it is affected.

What it is: CVE-2020-2205 is a medium-severity cross-site scripting vulnerability in Jenkins VncRecorder Plugin, published on 2 Jul 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2205 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:vncrecorder (Maven): affected all versions; fixed in 1.35
- org.jenkins-ci.plugins:vncrecorder (Maven): affected all versions; fixed in 1.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2205/ (Markdown: https://insights.sbomify.com/CVE-2020-2205/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2205
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2205
- OSV: https://osv.dev/vulnerability/CVE-2020-2205

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2205/
Summaries are generated and may contain mistakes; the official description above is the record.
