{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:vncrecorder. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2206 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:vncrecorder to 1.35 or later.","what":"CVE-2020-2206 is a medium-severity cross-site scripting vulnerability in Jenkins VncRecorder Plugin, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2206 and fix it if it is affected.\n\nWhat it is: CVE-2020-2206 is a medium-severity cross-site scripting vulnerability in Jenkins VncRecorder Plugin, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2206 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:vncrecorder (Maven): affected all versions; fixed in 1.35\n- org.jenkins-ci.plugins:vncrecorder (Maven): affected all versions; fixed in 1.35\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2206/ (Markdown: https://insights.sbomify.com/CVE-2020-2206/index.md)","id":"CVE-2020-2206","markdown":"https://insights.sbomify.com/CVE-2020-2206/index.md","name":"CVE-2020-2206","record":{"aliases":["GHSA-fq52-6cjf-jw59"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins VncRecorder Plugin","requires_auth":"none","summary":"Reflected XSS in Jenkins VncRecorder Plugin allows attackers to execute scripts in victim browsers via unescaped parameters.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"vncrecorder","vendor":"jenkins"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins VncRecorder Plugin 1.25 and earlier does not escape a parameter value in the checkVncServ form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected XSS vulnerability in Jenkins VncRecorder Plugin","id":"CVE-2020-2206","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Reflected XSS vulnerability in Jenkins VncViewer Plugin","id":"CVE-2020-2207"},"packages":[{"ecosystem":"Maven","fixed":["1.35"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:vncrecorder","purl":null,"source":"GHSA-fq52-6cjf-jw59"},{"ecosystem":"Maven","fixed":["1.35"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:vncrecorder","purl":"pkg:maven/org.jenkins-ci.plugins/vncrecorder","source":"GHSA-fq52-6cjf-jw59"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins VncRecorder Plugin","id":"CVE-2020-2205"},"products":["Jenkins VncRecorder Plugin"],"published":"2020-07-02","related":[{"cvss_score":4.8,"headline":"Stored XSS vulnerability in Jenkins VncRecorder Plugin","id":"CVE-2020-2205","kev_date_added":null,"published":"2020-07-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Reflected XSS in Jenkins VncRecorder Plugin allows attackers to execute scripts in victim browsers via unescaped parameters.","url":"https://insights.sbomify.com/CVE-2020-2206/"}