{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:vncviewer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2207 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:vncviewer to 1.8 or later.","what":"CVE-2020-2207 is a medium-severity cross-site scripting vulnerability in Jenkins VncViewer Plugin, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2207 and fix it if it is affected.\n\nWhat it is: CVE-2020-2207 is a medium-severity cross-site scripting vulnerability in Jenkins VncViewer Plugin, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2207 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:vncviewer (Maven): affected all versions; fixed in 1.8\n- org.jenkins-ci.plugins:vncviewer (Maven): affected all versions; fixed in 1.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2207/ (Markdown: https://insights.sbomify.com/CVE-2020-2207/index.md)","id":"CVE-2020-2207","markdown":"https://insights.sbomify.com/CVE-2020-2207/index.md","name":"CVE-2020-2207","record":{"aliases":["GHSA-2j4h-cjgh-659v"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins VncViewer Plugin","requires_auth":"none","summary":"Reflected XSS in Jenkins VncViewer Plugin allows attackers to execute arbitrary scripts in victim browsers via unescaped parameters.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"vncviewer","vendor":"jenkins"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins VncViewer Plugin 1.7 and earlier does not escape a parameter value in the checkVncServ form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected XSS vulnerability in Jenkins VncViewer Plugin","id":"CVE-2020-2207","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Secret stored in plain text by Jenkins Slack Upload Plugin","id":"CVE-2020-2208"},"packages":[{"ecosystem":"Maven","fixed":["1.8"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:vncviewer","purl":null,"source":"GHSA-2j4h-cjgh-659v"},{"ecosystem":"Maven","fixed":["1.8"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:vncviewer","purl":"pkg:maven/org.jenkins-ci.plugins/vncviewer","source":"GHSA-2j4h-cjgh-659v"}],"prev":{"headline":"Reflected XSS vulnerability in Jenkins VncRecorder Plugin","id":"CVE-2020-2206"},"products":["Jenkins VncViewer Plugin"],"published":"2020-07-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Reflected XSS in Jenkins VncViewer Plugin allows attackers to execute arbitrary scripts in victim browsers via unescaped parameters.","url":"https://insights.sbomify.com/CVE-2020-2207/"}