{"answers":{"affected":"3 open source packages ship an affected version, including jsonpickle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-22083 in the wild and no public exploit code.","fix":"Upgrade jsonpickle to 1.4.2 or later.","what":"CVE-2020-22083 is a critical unsafe deserialization vulnerability in n/a, published on 17 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-22083 and fix it if it is affected.\n\nWhat it is: CVE-2020-22083 is a critical unsafe deserialization vulnerability in n/a, published on 17 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-22083 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jsonpickle (PyPI): affected all versions up to 1.4.2; no fix listed\n- jsonpickle (PyPI): affected all versions up to 1.4.2; no fix listed\n- jsonpickle (PyPI): affected all versions; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-22083/ (Markdown: https://insights.sbomify.com/CVE-2020-22083/index.md)","id":"CVE-2020-22083","markdown":"https://insights.sbomify.com/CVE-2020-22083/index.md","name":"CVE-2020-22083","record":{"aliases":["DEBIAN-CVE-2020-22083","GHSA-j66q-qmrc-89rx","PYSEC-2020-49"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python jsonpickle library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by sending malicious payloads to the jsonpickle decode function, affecting applications using this Python library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jsonpickle","vendor":"jsonpickle_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"jsonpickle through 1.4.1 allows remote code execution during deserialization of a malicious payload through the decode() function. Note: It has been argued that this is expected and clearly documented behaviour. pickle is known to be capable of causing arbitrary code execution, and must not be used with un-trusted data","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"jsonpickle unsafe deserialization","id":"CVE-2020-22083","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":3,"n_references":6,"next":{"headline":"Code injection in n/a","id":"CVE-2020-22120"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.4.2"],"package":"jsonpickle","purl":null,"source":"GHSA-j66q-qmrc-89rx"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.4.2"],"package":"jsonpickle","purl":"pkg:pypi/jsonpickle","source":"GHSA-j66q-qmrc-89rx"},{"ecosystem":"PyPI","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"jsonpickle","purl":"pkg:pypi/jsonpickle","source":"PYSEC-2020-49"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2020-22079"},"products":["n/a"],"published":"2020-12-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code by sending malicious payloads to the jsonpickle decode function, affecting applications using this Python library.","url":"https://insights.sbomify.com/CVE-2020-22083/"}