# CVE-2020-22083: jsonpickle unsafe deserialization

> Remote attackers can execute arbitrary code by sending malicious payloads to the jsonpickle decode function, affecting applications using this Python library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-22083, GHSA-j66q-qmrc-89rx, PYSEC-2020-49

## What is CVE-2020-22083?

CVE-2020-22083 is a critical unsafe deserialization vulnerability in n/a, published on 17 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jsonpickle through 1.4.1 allows remote code execution during deserialization of a malicious payload through the decode() function. Note: It has been argued that this is expected and clearly documented behaviour. pickle is known to be capable of causing arbitrary code execution, and must not be used with un-trusted data

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-22083?

3 open source packages ship an affected version, including jsonpickle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsonpickle` | PyPI | All versions to 1.4.2 | None |
| `jsonpickle` | PyPI | All versions to 1.4.2 | None |
| `jsonpickle` | PyPI | All versions | 1.4.2 |

Products: Jsonpickle Project Jsonpickle.

## How do I fix CVE-2020-22083?

Upgrade jsonpickle to 1.4.2 or later.

## Is CVE-2020-22083 being exploited?

There is no known exploitation of CVE-2020-22083 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-22083 and fix it if it is affected.

What it is: CVE-2020-22083 is a critical unsafe deserialization vulnerability in n/a, published on 17 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-22083 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsonpickle (PyPI): affected all versions up to 1.4.2; no fix listed
- jsonpickle (PyPI): affected all versions up to 1.4.2; no fix listed
- jsonpickle (PyPI): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-22083/ (Markdown: https://insights.sbomify.com/CVE-2020-22083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-22083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-22083
- OSV: https://osv.dev/vulnerability/CVE-2020-22083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-22083/
Summaries are generated and may contain mistakes; the official description above is the record.
