# CVE-2020-2213: Credentials stored in plain text by Jenkins White Source Plugin

> Attackers with Extended Read permission or file system access can view unencrypted credentials stored in Jenkins WhiteSource Plugin configuration files.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v8v2-fhgv-3vq2

## What is CVE-2020-2213?

CVE-2020-2213 is a medium-severity vulnerability in Jenkins White Source Plugin, published on 2 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins White Source Plugin 19.1.1 and earlier stores credentials unencrypted in its global configuration file and in job config.xml files on the Jenkins master where they can be viewed by users with Extended Read permission (config.xml), or access to the master file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2020-2213?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:whitesource. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:whitesource` | Maven | All versions | 20.8.1 |
| `org.jenkins-ci.plugins:whitesource` | Maven | All versions | 20.8.1 |

Products: Jenkins White Source.

## How do I fix CVE-2020-2213?

Upgrade org.jenkins-ci.plugins:whitesource to 20.8.1 or later.

## Is CVE-2020-2213 being exploited?

There is no known exploitation of CVE-2020-2213 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2213 and fix it if it is affected.

What it is: CVE-2020-2213 is a medium-severity vulnerability in Jenkins White Source Plugin, published on 2 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2213 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:whitesource (Maven): affected all versions; fixed in 20.8.1
- org.jenkins-ci.plugins:whitesource (Maven): affected all versions; fixed in 20.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2213/ (Markdown: https://insights.sbomify.com/CVE-2020-2213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2213
- OSV: https://osv.dev/vulnerability/CVE-2020-2213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2213/
Summaries are generated and may contain mistakes; the official description above is the record.
