{"answers":{"affected":"2 open source packages ship an affected version, including com.vrondakis.zap:zap-pipeline. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2214 in the wild and no public exploit code.","fix":"Upgrade com.vrondakis.zap:zap-pipeline to 1.10 or later.","what":"CVE-2020-2214 is a medium-severity cross-site scripting vulnerability in Jenkins ZAP Pipeline Plugin, published on 2 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2214 and fix it if it is affected.\n\nWhat it is: CVE-2020-2214 is a medium-severity cross-site scripting vulnerability in Jenkins ZAP Pipeline Plugin, published on 2 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2214 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.vrondakis.zap:zap-pipeline (Maven): affected all versions; fixed in 1.10\n- com.vrondakis.zap:zap-pipeline (Maven): affected all versions; fixed in 1.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2214/ (Markdown: https://insights.sbomify.com/CVE-2020-2214/index.md)","id":"CVE-2020-2214","markdown":"https://insights.sbomify.com/CVE-2020-2214/index.md","name":"CVE-2020-2214","record":{"aliases":["GHSA-4c87-9xq5-5c35"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins ZAP Plugin","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in Jenkins workspaces because the plugin disables Content-Security-Policy protections for user-generated content.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"zap_pipeline","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins ZAP Pipeline Plugin 1.9 and earlier programmatically disables Content-Security-Policy protection for user-generated content in workspaces, archived artifacts, etc. that Jenkins offers for download.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Content-Security-Policy protection for user content disabled by Jenkins ZAP Pipeline Plugin","id":"CVE-2020-2214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability in Jenkins Zephyr for JIRA Test Management Plugin","id":"CVE-2020-2215"},"packages":[{"ecosystem":"Maven","fixed":["1.10"],"introduced":["0"],"last_affected":[],"package":"com.vrondakis.zap:zap-pipeline","purl":null,"source":"GHSA-4c87-9xq5-5c35"},{"ecosystem":"Maven","fixed":["1.10"],"introduced":["0"],"last_affected":[],"package":"com.vrondakis.zap:zap-pipeline","purl":"pkg:maven/com.vrondakis.zap/zap-pipeline","source":"GHSA-4c87-9xq5-5c35"}],"prev":{"headline":"Credentials stored in plain text by Jenkins White Source Plugin","id":"CVE-2020-2213"},"products":["Jenkins ZAP Pipeline Plugin"],"published":"2020-07-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can execute arbitrary scripts in Jenkins workspaces because the plugin disables Content-Security-Policy protections for user-generated content.","url":"https://insights.sbomify.com/CVE-2020-2214/"}