# CVE-2020-2221: Stored XSS vulnerability in Jenkins upstream cause

> Stored cross-site scripting in Jenkins allows attackers to execute arbitrary scripts via unescaped upstream job display names in build causes.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-jenkins-2020-2221, GHSA-g4j6-m3m3-crw8

## What is CVE-2020-2221?

CVE-2020-2221 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 15 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins 2.244 and earlier, LTS 2.235.1 and earlier does not escape the upstream job's display name shown as part of a build cause, resulting in a stored cross-site scripting vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2221?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.235.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.235.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.236 | 2.245 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.236 | 2.245 |
| `jenkins` | Bitnami | All versions | 2.244.1 |

Products: Jenkins Jenkins.

## How do I fix CVE-2020-2221?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.235.2 or 2.245.

## Is CVE-2020-2221 being exploited?

There is no known exploitation of CVE-2020-2221 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2221 and fix it if it is affected.

What it is: CVE-2020-2221 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 15 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2221 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.235.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.235.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.236; fixed in 2.245
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.236; fixed in 2.245
- jenkins (Bitnami): affected all versions; fixed in 2.244.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2221/ (Markdown: https://insights.sbomify.com/CVE-2020-2221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2221
- OSV: https://osv.dev/vulnerability/CVE-2020-2221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2221/
Summaries are generated and may contain mistakes; the official description above is the record.
