{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:deployer-framework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2227 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:deployer-framework to 1.3 or later.","what":"CVE-2020-2227 is a medium-severity cross-site scripting vulnerability in Jenkins Deployer Framework Plugin, published on 15 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2227 and fix it if it is affected.\n\nWhat it is: CVE-2020-2227 is a medium-severity cross-site scripting vulnerability in Jenkins Deployer Framework Plugin, published on 15 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2227 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:deployer-framework (Maven): affected all versions; fixed in 1.3\n- org.jenkins-ci.plugins:deployer-framework (Maven): affected all versions; fixed in 1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2227/ (Markdown: https://insights.sbomify.com/CVE-2020-2227/index.md)","id":"CVE-2020-2227","markdown":"https://insights.sbomify.com/CVE-2020-2227/index.md","name":"CVE-2020-2227","record":{"aliases":["GHSA-cfvw-84vq-43mx"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored cross-site scripting in Jenkins Deployer Framework Plugin allows attackers to execute arbitrary scripts in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"deployer_framework","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Deployer Framework Plugin 1.2 and earlier does not escape the URL displayed in the build home page, resulting in a stored cross-site scripting vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Jenkins Deployer Framework Plugin","id":"CVE-2020-2227","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Improper authorization of users and groups with the same base name in Jenkins GitLab Authentication Plugin","id":"CVE-2020-2228"},"packages":[{"ecosystem":"Maven","fixed":["1.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:deployer-framework","purl":null,"source":"GHSA-cfvw-84vq-43mx"},{"ecosystem":"Maven","fixed":["1.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:deployer-framework","purl":"pkg:maven/org.jenkins-ci.plugins/deployer-framework","source":"GHSA-cfvw-84vq-43mx"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins Matrix Authorization Strategy Plugin","id":"CVE-2020-2226"},"products":["Jenkins Deployer Framework Plugin"],"published":"2020-07-15","related":[{"cvss_score":8.8,"headline":"Jenkins Deployer Framework Plugin does not restrict application path of applications when configuring a deployment","id":"CVE-2022-36889","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":4.3,"headline":"Jenkins Deployer Framework Plugin vulnerable to Path Traversal","id":"CVE-2022-36890","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":4.3,"headline":"Jenkins Deployer Framework Plugin allows attackers with Item/Read permission to read deployment logs","id":"CVE-2022-36891","kev_date_added":null,"published":"2022-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Stored cross-site scripting in Jenkins Deployer Framework Plugin allows attackers to execute arbitrary scripts in victim browsers.","url":"https://insights.sbomify.com/CVE-2020-2227/"}