{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:gitlab-oauth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2228 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:gitlab-oauth to 1.6 or later.","what":"CVE-2020-2228 is a high-severity missing authorization vulnerability in Jenkins Gitlab Authentication Plugin, published on 15 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2228 and fix it if it is affected.\n\nWhat it is: CVE-2020-2228 is a high-severity missing authorization vulnerability in Jenkins Gitlab Authentication Plugin, published on 15 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2228 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:gitlab-oauth (Maven): affected all versions; fixed in 1.6\n- org.jenkins-ci.plugins:gitlab-oauth (Maven): affected all versions; fixed in 1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2228/ (Markdown: https://insights.sbomify.com/CVE-2020-2228/index.md)","id":"CVE-2020-2228","markdown":"https://insights.sbomify.com/CVE-2020-2228/index.md","name":"CVE-2020-2228","record":{"aliases":["GHSA-qq38-mxpq-rrpj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Gitlab Authentication Plugin","requires_auth":"low_privilege","summary":"Attackers can escalate privileges due to improper group authorization checks in the Jenkins Gitlab Authentication Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"gitlab_authentication","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Jenkins Gitlab Authentication Plugin 1.5 and earlier does not perform group authorization checks properly, resulting in a privilege escalation vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper authorization of users and groups with the same base name in Jenkins GitLab Authentication Plugin","id":"CVE-2020-2228","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Cross-Site Scripting vulnerability in help icons","id":"CVE-2020-2229"},"packages":[{"ecosystem":"Maven","fixed":["1.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:gitlab-oauth","purl":null,"source":"GHSA-qq38-mxpq-rrpj"},{"ecosystem":"Maven","fixed":["1.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:gitlab-oauth","purl":"pkg:maven/org.jenkins-ci.plugins/gitlab-oauth","source":"GHSA-qq38-mxpq-rrpj"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins Deployer Framework Plugin","id":"CVE-2020-2227"},"products":["Jenkins Gitlab Authentication Plugin"],"published":"2020-07-15","related":[{"cvss_score":6.5,"headline":"Client Secret stored in plain text by Jenkins GitLab Authentication Plugin","id":"CVE-2022-27206","kev_date_added":null,"published":"2022-03-15"},{"cvss_score":5.4,"headline":"CSRF vulnerability in GitLab Authentication Plugin","id":"CVE-2023-39153","kev_date_added":null,"published":"2023-07-26"},{"cvss_score":5.4,"headline":"Open redirect vulnerability in Jenkins GitLab Authentication Plugin","id":"CVE-2022-25196","kev_date_added":null,"published":"2022-02-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can escalate privileges due to improper group authorization checks in the Jenkins Gitlab Authentication Plugin.","url":"https://insights.sbomify.com/CVE-2020-2228/"}