# CVE-2020-2228: Improper authorization of users and groups with the same base name in Jenkins GitLab Authentication Plugin

> Attackers can escalate privileges due to improper group authorization checks in the Jenkins Gitlab Authentication Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qq38-mxpq-rrpj

## What is CVE-2020-2228?

CVE-2020-2228 is a high-severity missing authorization vulnerability in Jenkins Gitlab Authentication Plugin, published on 15 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Gitlab Authentication Plugin 1.5 and earlier does not perform group authorization checks properly, resulting in a privilege escalation vulnerability.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-2228?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:gitlab-oauth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:gitlab-oauth` | Maven | All versions | 1.6 |
| `org.jenkins-ci.plugins:gitlab-oauth` | Maven | All versions | 1.6 |

Products: Jenkins Gitlab Authentication.

## How do I fix CVE-2020-2228?

Upgrade org.jenkins-ci.plugins:gitlab-oauth to 1.6 or later.

## Is CVE-2020-2228 being exploited?

There is no known exploitation of CVE-2020-2228 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Gitlab Authentication Plugin

- [CVE-2022-27206](https://insights.sbomify.com/CVE-2022-27206/): Client Secret stored in plain text by Jenkins GitLab Authentication Plugin (medium 6.5)
- [CVE-2023-39153](https://insights.sbomify.com/CVE-2023-39153/): CSRF vulnerability in GitLab Authentication Plugin (medium 5.4)
- [CVE-2022-25196](https://insights.sbomify.com/CVE-2022-25196/): Open redirect vulnerability in Jenkins GitLab Authentication Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2228 and fix it if it is affected.

What it is: CVE-2020-2228 is a high-severity missing authorization vulnerability in Jenkins Gitlab Authentication Plugin, published on 15 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2228 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:gitlab-oauth (Maven): affected all versions; fixed in 1.6
- org.jenkins-ci.plugins:gitlab-oauth (Maven): affected all versions; fixed in 1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2228/ (Markdown: https://insights.sbomify.com/CVE-2020-2228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2228
- OSV: https://osv.dev/vulnerability/CVE-2020-2228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2228/
Summaries are generated and may contain mistakes; the official description above is the record.
