{"answers":{"affected":"2 open source packages ship an affected version, including com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2236 in the wild and no public exploit code.","fix":"Upgrade com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer to 1.12 or later.","what":"CVE-2020-2236 is a medium-severity cross-site scripting vulnerability in Jenkins Yet Another Build Visualizer Plugin, published on 12 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2236 and fix it if it is affected.\n\nWhat it is: CVE-2020-2236 is a medium-severity cross-site scripting vulnerability in Jenkins Yet Another Build Visualizer Plugin, published on 12 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2236 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer (Maven): affected all versions; fixed in 1.12\n- com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer (Maven): affected all versions; fixed in 1.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2236/ (Markdown: https://insights.sbomify.com/CVE-2020-2236/index.md)","id":"CVE-2020-2236","markdown":"https://insights.sbomify.com/CVE-2020-2236/index.md","name":"CVE-2020-2236","record":{"aliases":["GHSA-3mwj-7vmq-w43p"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Yet Another Build Visualizer Plugin allows attackers with Run/Update permission to execute scripts in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"yet_another_build_visualizer","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Yet Another Build Visualizer Plugin 1.11 and earlier does not escape tooltip content, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by users with Run/Update permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Jenkins Yet Another Build Visualizer Plugin","id":"CVE-2020-2236","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability in Jenkins Flaky Test Handler Plugin","id":"CVE-2020-2237"},"packages":[{"ecosystem":"Maven","fixed":["1.12"],"introduced":["0"],"last_affected":[],"package":"com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer","purl":null,"source":"GHSA-3mwj-7vmq-w43p"},{"ecosystem":"Maven","fixed":["1.12"],"introduced":["0"],"last_affected":[],"package":"com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer","purl":"pkg:maven/com.axis.system.jenkins.plugins.downstream/yet-another-build-visualizer","source":"GHSA-3mwj-7vmq-w43p"}],"prev":{"headline":"CSRF vulnerability in Jenkins Pipeline Maven Integration Plugin allow capturing credentials","id":"CVE-2020-2235"},"products":["Jenkins Yet Another Build Visualizer Plugin"],"published":"2020-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Yet Another Build Visualizer Plugin allows attackers with Run/Update permission to execute scripts in victim browsers.","url":"https://insights.sbomify.com/CVE-2020-2236/"}