# CVE-2020-2236: Stored XSS vulnerability in Jenkins Yet Another Build Visualizer Plugin

> Stored XSS in Jenkins Yet Another Build Visualizer Plugin allows attackers with Run/Update permission to execute scripts in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3mwj-7vmq-w43p

## What is CVE-2020-2236?

CVE-2020-2236 is a medium-severity cross-site scripting vulnerability in Jenkins Yet Another Build Visualizer Plugin, published on 12 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Yet Another Build Visualizer Plugin 1.11 and earlier does not escape tooltip content, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by users with Run/Update permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2236?

2 open source packages ship an affected version, including com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer` | Maven | All versions | 1.12 |
| `com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer` | Maven | All versions | 1.12 |

Products: Jenkins Yet Another Build Visualizer.

## How do I fix CVE-2020-2236?

Upgrade com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer to 1.12 or later.

## Is CVE-2020-2236 being exploited?

There is no known exploitation of CVE-2020-2236 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2236 and fix it if it is affected.

What it is: CVE-2020-2236 is a medium-severity cross-site scripting vulnerability in Jenkins Yet Another Build Visualizer Plugin, published on 12 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2236 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer (Maven): affected all versions; fixed in 1.12
- com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer (Maven): affected all versions; fixed in 1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2236/ (Markdown: https://insights.sbomify.com/CVE-2020-2236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2236
- OSV: https://osv.dev/vulnerability/CVE-2020-2236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2236/
Summaries are generated and may contain mistakes; the official description above is the record.
