{"answers":{"affected":"2 open source packages ship an affected version, including express-cart. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-22403 in the wild and no public exploit code.","fix":"Upgrade express-cart to 1.1.17 or later.","what":"CVE-2020-22403 is a high-severity vulnerability in n/a, published on 12 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-22403 and fix it if it is affected.\n\nWhat it is: CVE-2020-22403 is a high-severity vulnerability in n/a, published on 12 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-22403 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-cart (npm): affected all versions; fixed in 1.1.17\n- express-cart (npm): affected all versions; fixed in 1.1.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-22403/ (Markdown: https://insights.sbomify.com/CVE-2020-22403/index.md)","id":"CVE-2020-22403","markdown":"https://insights.sbomify.com/CVE-2020-22403/index.md","name":"CVE-2020-22403","record":{"aliases":["GHSA-h5q8-5697-9p9h"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Express cart","requires_auth":"none","summary":"Attackers can exploit CSRF in Express cart to add administrator accounts or modify discount codes, requiring user interaction.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"express-cart","vendor":"express-cart_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross Site Request Forgery (CSRF) vulnerability in Express cart v1.1.16 allows attackers to add an administrator account, add discount code or other unspecified impacts.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery in express-cart","id":"CVE-2020-22403","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-22421"},"packages":[{"ecosystem":"npm","fixed":["1.1.17"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":null,"source":"GHSA-h5q8-5697-9p9h"},{"ecosystem":"npm","fixed":["1.1.17"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":"pkg:npm/express-cart","source":"GHSA-h5q8-5697-9p9h"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-22402"},"products":["n/a"],"published":"2021-08-12","related":[{"cvss_score":8.8,"headline":"Authentication Bypass by Spoofing in express-cart","id":"CVE-2018-16483","kev_date_added":null,"published":"2019-02-01"},{"cvss_score":8.8,"headline":"express-cart unrestricted file upload vulnerability","id":"CVE-2018-3758","kev_date_added":null,"published":"2018-06-07"},{"cvss_score":4.8,"headline":"Cross-site Scripting in express-cart","id":"CVE-2021-32573","kev_date_added":null,"published":"2021-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can exploit CSRF in Express cart to add administrator accounts or modify discount codes, requiring user interaction.","url":"https://insights.sbomify.com/CVE-2020-22403/"}