CVE-2020-2252 Improper Validation of Certificate with Host Mismatch in Jenkins Mailer Plugin
The Jenkins Mailer Plugin fails to validate SMTP server hostnames, allowing attackers to bypass security controls or redirect traffic.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-2252?
CVE-2020-2252 is a medium-severity server-side request forgery vulnerability in Jenkins Mailer Plugin, published on 16 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jenkins Mailer Plugin 1.32 and earlier does not perform hostname validation when connecting to the configured SMTP server.
Weakness: CWE-295
Which versions are affected by CVE-2020-2252?
6 open source packages ship an affected version, including org.jenkins-ci.plugins:mailer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.plugins:mailer Maven | All versions | 1.29.1 |
org.jenkins-ci.plugins:mailer Maven | All versions | 1.29.1 |
org.jenkins-ci.plugins:mailer Maven | From 1.30 | 1.31.1 |
org.jenkins-ci.plugins:mailer Maven | From 1.30 | 1.31.1 |
org.jenkins-ci.plugins:mailer Maven | From 1.32 | 1.32.1 |
org.jenkins-ci.plugins:mailer Maven | From 1.32 | 1.32.1 |
Products include Jenkins Mailer.
How do I fix CVE-2020-2252?
Upgrade org.jenkins-ci.plugins:mailer to a fixed version for your release line: 1.29.1, 1.31.1 or 1.32.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2020-2252 being exploited?
There is no known exploitation of CVE-2020-2252 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Mailer Plugin
- CVE-2018-8718 Cross-Site Request Forgery in Jenkins Mailer Plugin
- CVE-2022-20613 Cross-Site Request Forgery in Jenkins Mailer Plugin
- CVE-2022-20614 Incorrect Permission Assignment for Critical Resource in Jenkins Mailer Plugin
- CVE-2017-2651 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins-mailer-plugin
Sources
Also known as GHSA-6fr3-286q-q3cr.