{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:validating-string-parameter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2257 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:validating-string-parameter to 2.5 or later.","what":"CVE-2020-2257 is a medium-severity cross-site scripting vulnerability in Jenkins Validating String Parameter Plugin, published on 16 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2257 and fix it if it is affected.\n\nWhat it is: CVE-2020-2257 is a medium-severity cross-site scripting vulnerability in Jenkins Validating String Parameter Plugin, published on 16 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2257 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:validating-string-parameter (Maven): affected all versions; fixed in 2.5\n- org.jenkins-ci.plugins:validating-string-parameter (Maven): affected all versions; fixed in 2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2257/ (Markdown: https://insights.sbomify.com/CVE-2020-2257/index.md)","id":"CVE-2020-2257","markdown":"https://insights.sbomify.com/CVE-2020-2257/index.md","name":"CVE-2020-2257","record":{"aliases":["GHSA-fvwh-wv43-8qj5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Validating String Parameter Plugin allows attackers with Job/Configure permission to execute scripts in other users' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"validating_string_parameter","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Validating String Parameter Plugin 2.4 and earlier does not escape various user-controlled fields, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Validating String Parameter Plugin","id":"CVE-2020-2257","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Incorrect permission check in Health Advisor by CloudBees Plugin","id":"CVE-2020-2258"},"packages":[{"ecosystem":"Maven","fixed":["2.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:validating-string-parameter","purl":null,"source":"GHSA-fvwh-wv43-8qj5"},{"ecosystem":"Maven","fixed":["2.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:validating-string-parameter","purl":"pkg:maven/org.jenkins-ci.plugins/validating-string-parameter","source":"GHSA-fvwh-wv43-8qj5"}],"prev":{"headline":"Stored XSS vulnerability in Pipeline Maven Integration Plugin via unescaped display name","id":"CVE-2020-2256"},"products":["Jenkins Validating String Parameter Plugin"],"published":"2020-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Validating String Parameter Plugin allows attackers with Job/Configure permission to execute scripts in other users' browsers.","url":"https://insights.sbomify.com/CVE-2020-2257/"}