{"answers":{"affected":"1 open source package ship an affected version, including memcached. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-22570 exists.","fix":"Upgrade memcached to 1.6.3 or later.","what":"CVE-2020-22570 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-22570 and fix it if it is affected.\n\nWhat it is: CVE-2020-22570 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-22570 exists.\n\nAffected packages and fixed versions:\n- memcached (Bitnami): affected from 1.6.0; fixed in 1.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-22570/ (Markdown: https://insights.sbomify.com/CVE-2020-22570/index.md)","id":"CVE-2020-22570","markdown":"https://insights.sbomify.com/CVE-2020-22570/index.md","name":"CVE-2020-22570","record":{"aliases":["BIT-memcached-2020-22570","DEBIAN-CVE-2020-22570","GHSA-fq43-fxrw-vjrh"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Memcached server","requires_auth":"none","summary":"Remote attackers can crash the Memcached daemon by sending a crafted meta command, requiring an upgrade to a patched version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"memcached","vendor":"memcached"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Memcached 1.6.0 before 1.6.3 allows remote attackers to cause a denial of service (daemon crash) via a crafted meta command.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2020-22570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":1,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-22597"},"packages":[{"ecosystem":"Bitnami","fixed":["1.6.3"],"introduced":["1.6.0"],"last_affected":[],"package":"memcached","purl":"pkg:bitnami/memcached","source":"BIT-memcached-2020-22570"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2020-22552"},"products":["n/a"],"published":"2023-08-22","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2023-46853","kev_date_added":null,"published":"2023-10-27"},{"cvss_score":9.8,"headline":"Integer overflow in Memcached","id":"CVE-2016-8704","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":9.8,"headline":"Integer overflow in Memcached","id":"CVE-2016-8705","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":8.1,"headline":"Information disclosure in memcached","id":"CVE-2026-47783","kev_date_added":null,"published":"2026-05-20"},{"cvss_score":8.1,"headline":"Information disclosure in memcached","id":"CVE-2026-47784","kev_date_added":null,"published":"2026-05-20"},{"cvss_score":8.1,"headline":"Integer overflow in Memcached","id":"CVE-2016-8706","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2023-46852","kev_date_added":null,"published":"2023-10-27"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["n/a"]},"summary":"Remote attackers can crash the Memcached daemon by sending a crafted meta command, requiring an upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2020-22570/"}