# CVE-2020-2258: Incorrect permission check in Health Advisor by CloudBees Plugin

> Attackers with read permissions can access restricted HTTP endpoints in the Jenkins Health Advisor plugin due to missing authorization checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c445-xm3f-hmfh

## What is CVE-2020-2258?

CVE-2020-2258 is a medium-severity missing authorization vulnerability in Jenkins Health Advisor by CloudBees Plugin, published on 16 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Health Advisor by CloudBees Plugin 3.2.0 and earlier does not correctly perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to view that HTTP endpoint.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-2258?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:cloudbees-jenkins-advisor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:cloudbees-jenkins-advisor` | Maven | All versions | 3.2.1 |
| `org.jenkins-ci.plugins:cloudbees-jenkins-advisor` | Maven | All versions | 3.2.1 |

Products: Jenkins Health Advisor by Cloudbees.

## How do I fix CVE-2020-2258?

Upgrade org.jenkins-ci.plugins:cloudbees-jenkins-advisor to 3.2.1 or later.

## Is CVE-2020-2258 being exploited?

There is no known exploitation of CVE-2020-2258 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Health Advisor by CloudBees Plugin

- [CVE-2025-47885](https://insights.sbomify.com/CVE-2025-47885/): Jenkins Health Advisor by CloudBees Plugin Vulnerable to Cross-Site Scripting (high 8.8)
- [CVE-2020-2093](https://insights.sbomify.com/CVE-2020-2093/): CSRF vulnerability in Health Advisor by CloudBees Plugin (high 8.8)
- [CVE-2020-2094](https://insights.sbomify.com/CVE-2020-2094/): Missing permission checks in Health Advisor by CloudBees Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2258 and fix it if it is affected.

What it is: CVE-2020-2258 is a medium-severity missing authorization vulnerability in Jenkins Health Advisor by CloudBees Plugin, published on 16 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2258 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:cloudbees-jenkins-advisor (Maven): affected all versions; fixed in 3.2.1
- org.jenkins-ci.plugins:cloudbees-jenkins-advisor (Maven): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2258/ (Markdown: https://insights.sbomify.com/CVE-2020-2258/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2258
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2258
- OSV: https://osv.dev/vulnerability/CVE-2020-2258

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2258/
Summaries are generated and may contain mistakes; the official description above is the record.
