# CVE-2020-2259: Stored XSS vulnerability in computer-queue-plugin Plugin

> Stored XSS in Jenkins computer-queue-plugin allows attackers with Agent/Configure permission to execute scripts in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qg66-xv7v-m834

## What is CVE-2020-2259?

CVE-2020-2259 is a medium-severity cross-site scripting vulnerability in Jenkins computer-queue-plugin Plugin, published on 16 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins computer-queue-plugin Plugin 1.5 and earlier does not escape the agent name in tooltips, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2259?

2 open source packages ship an affected version, including jenkins.ci.plugins.computerqueue:computer-queue-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jenkins.ci.plugins.computerqueue:computer-queue-plugin` | Maven | All versions | 1.6 |
| `jenkins.ci.plugins.computerqueue:computer-queue-plugin` | Maven | All versions | 1.6 |

Products: Jenkins Computer Queue.

## How do I fix CVE-2020-2259?

Upgrade jenkins.ci.plugins.computerqueue:computer-queue-plugin to 1.6 or later.

## Is CVE-2020-2259 being exploited?

There is no known exploitation of CVE-2020-2259 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2259 and fix it if it is affected.

What it is: CVE-2020-2259 is a medium-severity cross-site scripting vulnerability in Jenkins computer-queue-plugin Plugin, published on 16 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2259 in the wild and no public exploit code.

Affected packages and fixed versions:
- jenkins.ci.plugins.computerqueue:computer-queue-plugin (Maven): affected all versions; fixed in 1.6
- jenkins.ci.plugins.computerqueue:computer-queue-plugin (Maven): affected all versions; fixed in 1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2259/ (Markdown: https://insights.sbomify.com/CVE-2020-2259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2259
- OSV: https://osv.dev/vulnerability/CVE-2020-2259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2259/
Summaries are generated and may contain mistakes; the official description above is the record.
