# CVE-2020-22607: Cross-site scripting in n/a

> Cross-site scripting in LimeSurvey allows attackers to inject malicious scripts via name and description parameters, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-limesurvey-2020-22607, GHSA-mj23-7m3m-wqph

## What is CVE-2020-22607?

CVE-2020-22607 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting vulnerabilty in LimeSurvey 4.1.11+200316 via the (1) name and (2) description parameters in application/controllers/admin/PermissiontemplatesController.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-22607?

1 open source package ship an affected version, including limesurvey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `limesurvey` | Bitnami | From 4.1.11 | 4.1.12 |

Products: Limesurvey Limesurvey.

## How do I fix CVE-2020-22607?

Upgrade limesurvey to 4.1.12 or later.

## Is CVE-2020-22607 being exploited?

There is no known exploitation of CVE-2020-22607 in the wild and no public exploit code.

## Other vulnerabilities in Limesurvey Limesurvey

- [CVE-2025-56422](https://insights.sbomify.com/CVE-2025-56422/): Deserialization in n/a (critical 9.8)
- [CVE-2022-48008](https://insights.sbomify.com/CVE-2022-48008/): File upload in n/a (critical 9.8)
- [CVE-2019-25019](https://insights.sbomify.com/CVE-2019-25019/): SQL injection in n/a (critical 9.8)
- [CVE-2020-11455](https://insights.sbomify.com/CVE-2020-11455/): Path traversal in n/a (critical 9.8)
- [CVE-2019-16184](https://insights.sbomify.com/CVE-2019-16184/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-22607 and fix it if it is affected.

What it is: CVE-2020-22607 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-22607 in the wild and no public exploit code.

Affected packages and fixed versions:
- limesurvey (Bitnami): affected from 4.1.11; fixed in 4.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-22607/ (Markdown: https://insights.sbomify.com/CVE-2020-22607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-22607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-22607
- OSV: https://osv.dev/vulnerability/CVE-2020-22607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-22607/
Summaries are generated and may contain mistakes; the official description above is the record.
