# CVE-2020-22612: Code injection in n/a

> An attacker can execute arbitrary code by exploiting a vulnerability in the MyBB installer's settings file write process.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2023
- **Updated:** 1 Oct 2024
- **Also known as:** BIT-mybb-2020-22612, GHSA-pm38-4f58-28pj

## What is CVE-2020-22612?

CVE-2020-22612 is a critical code injection vulnerability in Mybb Mybb, published on 1 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Installer RCE on settings file write in MyBB before 1.8.22.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-22612?

1 open source package ship an affected version, including mybb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mybb` | Bitnami | All versions | 1.8.22 |

Products: Mybb Mybb.

## How do I fix CVE-2020-22612?

Upgrade mybb to 1.8.22 or later.

## Is CVE-2020-22612 being exploited?

There is no known exploitation of CVE-2020-22612 in the wild and no public exploit code.

## Other vulnerabilities in Mybb Mybb

- [CVE-2011-10018](https://insights.sbomify.com/CVE-2011-10018/): myBB 1.6.4 Backdoor Arbitrary Command Execution (critical 10.0)
- [CVE-2015-2786](https://insights.sbomify.com/CVE-2015-2786/): Information disclosure in n/a (critical 10.0)
- [CVE-2011-5133](https://insights.sbomify.com/CVE-2011-5133/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2006-0218](https://insights.sbomify.com/CVE-2006-0218/): SQL injection in n/a (critical 10.0)
- [CVE-2017-16780](https://insights.sbomify.com/CVE-2017-16780/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-22612 and fix it if it is affected.

What it is: CVE-2020-22612 is a critical code injection vulnerability in Mybb Mybb, published on 1 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-22612 in the wild and no public exploit code.

Affected packages and fixed versions:
- mybb (Bitnami): affected all versions; fixed in 1.8.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-22612/ (Markdown: https://insights.sbomify.com/CVE-2020-22612/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-22612
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-22612
- OSV: https://osv.dev/vulnerability/CVE-2020-22612

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-22612/
Summaries are generated and may contain mistakes; the official description above is the record.
