CVE-2020-2279 Sandbox bypass vulnerability in Jenkins Script Security Plugin

Critical 9.9 Published Updated

Attackers with script definition permissions can bypass the sandbox to execute arbitrary code on the Jenkins controller.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-2279?

CVE-2020-2279 is a critical code injection vulnerability in Jenkins Script Security Plugin, published on 23 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.74 and earlier allows attackers with permission to define sandboxed scripts to provide crafted return values or script binding content that can result in arbitrary code execution on the Jenkins controller JVM.

Which versions are affected by CVE-2020-2279?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.plugins:script-security MavenAll versions1.66.5
org.jenkins-ci.plugins:script-security MavenAll versions1.66.5
org.jenkins-ci.plugins:script-security MavenFrom 1.671.75
org.jenkins-ci.plugins:script-security MavenFrom 1.671.75

Products include Jenkins Script Security.

How do I fix CVE-2020-2279?

Upgrade org.jenkins-ci.plugins:script-security to a fixed version for your release line: 1.66.5 or 1.75.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2020-2279 being exploited?

There is no known exploitation of CVE-2020-2279 in the wild and no public exploit code.

Sources

Also known as GHSA-ccr8-4xr7-cgj3.

Is CVE-2020-2279 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free