# CVE-2020-2279: Sandbox bypass vulnerability in Jenkins Script Security Plugin

> Attackers with script definition permissions can bypass the sandbox to execute arbitrary code on the Jenkins controller.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-ccr8-4xr7-cgj3

## What is CVE-2020-2279?

CVE-2020-2279 is a critical code injection vulnerability in Jenkins Script Security Plugin, published on 23 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.74 and earlier allows attackers with permission to define sandboxed scripts to provide crafted return values or script binding content that can result in arbitrary code execution on the Jenkins controller JVM.

## Which versions are affected by CVE-2020-2279?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.66.5 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.66.5 |
| `org.jenkins-ci.plugins:script-security` | Maven | From 1.67 | 1.75 |
| `org.jenkins-ci.plugins:script-security` | Maven | From 1.67 | 1.75 |

Products: Jenkins Script Security.

## How do I fix CVE-2020-2279?

Upgrade org.jenkins-ci.plugins:script-security to a fixed version for your release line: 1.66.5 or 1.75.

## Is CVE-2020-2279 being exploited?

There is no known exploitation of CVE-2020-2279 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Script Security Plugin

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2019-10431](https://insights.sbomify.com/CVE-2019-10431/): Improper Control of Generation of Code in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2279 and fix it if it is affected.

What it is: CVE-2020-2279 is a critical code injection vulnerability in Jenkins Script Security Plugin, published on 23 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2279 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.66.5
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.66.5
- org.jenkins-ci.plugins:script-security (Maven): affected from 1.67; fixed in 1.75
- org.jenkins-ci.plugins:script-security (Maven): affected from 1.67; fixed in 1.75

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2279/ (Markdown: https://insights.sbomify.com/CVE-2020-2279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2279
- OSV: https://osv.dev/vulnerability/CVE-2020-2279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2279/
Summaries are generated and may contain mistakes; the official description above is the record.
