# CVE-2020-2280: CSRF vulnerability in Jenkins warnings Plugin allows remote code execution

> Attackers can exploit CSRF in the Jenkins Warnings Plugin to execute arbitrary code on the server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q564-vvx8-9388

## What is CVE-2020-2280?

CVE-2020-2280 is a high-severity vulnerability in Jenkins Warnings Plugin, published on 23 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-2280?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:warnings. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jvnet.hudson.plugins:warnings` | Maven | All versions | 5.0.2 |
| `org.jvnet.hudson.plugins:warnings` | Maven | All versions | 5.0.2 |

Products: Jenkins Warnings.

## How do I fix CVE-2020-2280?

Upgrade org.jvnet.hudson.plugins:warnings to 5.0.2 or later.

## Is CVE-2020-2280 being exploited?

There is no known exploitation of CVE-2020-2280 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Warnings Plugin

- [CVE-2019-1003007](https://insights.sbomify.com/CVE-2019-1003007/): Sandbox Bypass via CSRF in Jenkins Warnings Plugin (high 8.8)
- [CVE-2018-1000012](https://insights.sbomify.com/CVE-2018-1000012/): XXE vulnerability Jenkins Warnings Plugin (high 8.8)
- [CVE-2023-46651](https://insights.sbomify.com/CVE-2023-46651/): Jenkins Warnings Plugin exposures system-scoped credentials (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2280 and fix it if it is affected.

What it is: CVE-2020-2280 is a high-severity vulnerability in Jenkins Warnings Plugin, published on 23 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2280 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jvnet.hudson.plugins:warnings (Maven): affected all versions; fixed in 5.0.2
- org.jvnet.hudson.plugins:warnings (Maven): affected all versions; fixed in 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2280/ (Markdown: https://insights.sbomify.com/CVE-2020-2280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2280
- OSV: https://osv.dev/vulnerability/CVE-2020-2280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2280/
Summaries are generated and may contain mistakes; the official description above is the record.
