# CVE-2020-2281: CSRF vulnerability in Jenkins Lockable Resources Plugin

> Attackers can exploit CSRF to reserve, unreserve, unlock, or reset resources in the Jenkins Lockable Resources Plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rvww-w62m-hch8

## What is CVE-2020-2281?

CVE-2020-2281 is a medium-severity vulnerability in Jenkins Lockable Resources Plugin, published on 23 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins Lockable Resources Plugin 2.8 and earlier allows attackers to reserve, unreserve, unlock, and reset resources.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-2281?

2 open source packages ship an affected version, including org.6wind.jenkins:lockable-resources. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.6wind.jenkins:lockable-resources` | Maven | All versions | 2.9 |
| `org.6wind.jenkins:lockable-resources` | Maven | All versions | 2.9 |

Products: Jenkins Lockable Resources.

## How do I fix CVE-2020-2281?

Upgrade org.6wind.jenkins:lockable-resources to 2.9 or later.

## Is CVE-2020-2281 being exploited?

There is no known exploitation of CVE-2020-2281 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Lockable Resources Plugin

- [CVE-2019-1003042](https://insights.sbomify.com/CVE-2019-1003042/): Jenkins Lockable Resources Plugin XSS vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2281 and fix it if it is affected.

What it is: CVE-2020-2281 is a medium-severity vulnerability in Jenkins Lockable Resources Plugin, published on 23 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2281 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.6wind.jenkins:lockable-resources (Maven): affected all versions; fixed in 2.9
- org.6wind.jenkins:lockable-resources (Maven): affected all versions; fixed in 2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2281/ (Markdown: https://insights.sbomify.com/CVE-2020-2281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2281
- OSV: https://osv.dev/vulnerability/CVE-2020-2281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2281/
Summaries are generated and may contain mistakes; the official description above is the record.
