{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:implied-labels. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2282 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:implied-labels to 0.7 or later.","what":"CVE-2020-2282 is a medium-severity missing authorization vulnerability in Jenkins Implied Labels Plugin, published on 23 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2282 and fix it if it is affected.\n\nWhat it is: CVE-2020-2282 is a medium-severity missing authorization vulnerability in Jenkins Implied Labels Plugin, published on 23 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2282 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:implied-labels (Maven): affected all versions; fixed in 0.7\n- org.jenkins-ci.plugins:implied-labels (Maven): affected all versions; fixed in 0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2282/ (Markdown: https://insights.sbomify.com/CVE-2020-2282/index.md)","id":"CVE-2020-2282","markdown":"https://insights.sbomify.com/CVE-2020-2282/index.md","name":"CVE-2020-2282","record":{"aliases":["GHSA-5hw2-327v-vvr6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can modify plugin configuration due to missing permission checks in the Jenkins Implied Labels Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"implied_labels","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Jenkins Implied Labels Plugin 0.6 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to configure the plugin.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing permission check in Jenkins Implied Labels Plugin allows reconfiguring the plugin","id":"CVE-2020-2282","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Stored XSS vulnerability in Jenkins Liquibase Runner Plugin","id":"CVE-2020-2283"},"packages":[{"ecosystem":"Maven","fixed":["0.7"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:implied-labels","purl":null,"source":"GHSA-5hw2-327v-vvr6"},{"ecosystem":"Maven","fixed":["0.7"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:implied-labels","purl":"pkg:maven/org.jenkins-ci.plugins/implied-labels","source":"GHSA-5hw2-327v-vvr6"}],"prev":{"headline":"CSRF vulnerability in Jenkins Lockable Resources Plugin","id":"CVE-2020-2281"},"products":["Jenkins Implied Labels Plugin"],"published":"2020-09-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can modify plugin configuration due to missing permission checks in the Jenkins Implied Labels Plugin.","url":"https://insights.sbomify.com/CVE-2020-2282/"}