# CVE-2020-2282: Missing permission check in Jenkins Implied Labels Plugin allows reconfiguring the plugin

> Attackers with read permissions can modify plugin configuration due to missing permission checks in the Jenkins Implied Labels Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5hw2-327v-vvr6

## What is CVE-2020-2282?

CVE-2020-2282 is a medium-severity missing authorization vulnerability in Jenkins Implied Labels Plugin, published on 23 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Implied Labels Plugin 0.6 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to configure the plugin.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2020-2282?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:implied-labels. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:implied-labels` | Maven | All versions | 0.7 |
| `org.jenkins-ci.plugins:implied-labels` | Maven | All versions | 0.7 |

Products: Jenkins Implied Labels.

## How do I fix CVE-2020-2282?

Upgrade org.jenkins-ci.plugins:implied-labels to 0.7 or later.

## Is CVE-2020-2282 being exploited?

There is no known exploitation of CVE-2020-2282 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2282 and fix it if it is affected.

What it is: CVE-2020-2282 is a medium-severity missing authorization vulnerability in Jenkins Implied Labels Plugin, published on 23 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2282 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:implied-labels (Maven): affected all versions; fixed in 0.7
- org.jenkins-ci.plugins:implied-labels (Maven): affected all versions; fixed in 0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2282/ (Markdown: https://insights.sbomify.com/CVE-2020-2282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2282
- OSV: https://osv.dev/vulnerability/CVE-2020-2282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2282/
Summaries are generated and may contain mistakes; the official description above is the record.
