{"answers":{"affected":"2 open source packages ship an affected version, including froala-editor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-22864 in the wild and no public exploit code.","fix":"Upgrade froala-editor to 4.0.11 or later.","what":"CVE-2020-22864 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-22864 and fix it if it is affected.\n\nWhat it is: CVE-2020-22864 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-22864 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- froala-editor (npm): affected all versions; fixed in 4.0.11\n- froala-editor (npm): affected all versions; fixed in 4.0.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-22864/ (Markdown: https://insights.sbomify.com/CVE-2020-22864/index.md)","id":"CVE-2020-22864","markdown":"https://insights.sbomify.com/CVE-2020-22864/index.md","name":"CVE-2020-22864","record":{"aliases":["GHSA-97x5-cc53-cv4v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WYSIWYG editor library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via the Insert Video function in Froala WYSIWYG Editor, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"froala_editor","vendor":"froala"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG Editor 3.1.0 allows attackers to execute arbitrary web scripts or HTML.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross site scripting in froala-editor","id":"CVE-2020-22864","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-22873"},"packages":[{"ecosystem":"npm","fixed":["4.0.11"],"introduced":["0"],"last_affected":[],"package":"froala-editor","purl":null,"source":"GHSA-97x5-cc53-cv4v"},{"ecosystem":"npm","fixed":["4.0.11"],"introduced":["0"],"last_affected":[],"package":"froala-editor","purl":"pkg:npm/froala-editor","source":"GHSA-97x5-cc53-cv4v"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2020-22848"},"products":["n/a"],"published":"2021-10-26","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-43263","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-42426","kev_date_added":null,"published":"2023-09-25"},{"cvss_score":6.1,"headline":"Cross-site Scripting in Froala Editor","id":"CVE-2021-30109","kev_date_added":null,"published":"2021-04-05"},{"cvss_score":6.1,"headline":"Froala WYSIWYG Editor XSS Vulnerability","id":"CVE-2020-26523","kev_date_added":null,"published":"2020-10-02"},{"cvss_score":6.1,"headline":"DOM-based cross-site scripting in Froala Editor","id":"CVE-2019-19935","kev_date_added":null,"published":"2020-07-07"},{"cvss_score":5.4,"headline":"Froala Editor Cross-site Scripting vulnerability","id":"CVE-2023-41592","kev_date_added":null,"published":"2023-09-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via the Insert Video function in Froala WYSIWYG Editor, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2020-22864/"}