# CVE-2020-22864: Cross site scripting in froala-editor

> Attackers can execute arbitrary scripts via the Insert Video function in Froala WYSIWYG Editor, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-97x5-cc53-cv4v

## What is CVE-2020-22864?

CVE-2020-22864 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG Editor 3.1.0 allows attackers to execute arbitrary web scripts or HTML.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-22864?

2 open source packages ship an affected version, including froala-editor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froala-editor` | npm | All versions | 4.0.11 |
| `froala-editor` | npm | All versions | 4.0.11 |

Products: Froala Froala Editor.

## How do I fix CVE-2020-22864?

Upgrade froala-editor to 4.0.11 or later.

## Is CVE-2020-22864 being exploited?

There is no known exploitation of CVE-2020-22864 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-43263](https://insights.sbomify.com/CVE-2023-43263/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-42426](https://insights.sbomify.com/CVE-2023-42426/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2021-30109](https://insights.sbomify.com/CVE-2021-30109/): Cross-site Scripting in Froala Editor (medium 6.1)
- [CVE-2020-26523](https://insights.sbomify.com/CVE-2020-26523/): Froala WYSIWYG Editor XSS Vulnerability (medium 6.1)
- [CVE-2019-19935](https://insights.sbomify.com/CVE-2019-19935/): DOM-based cross-site scripting in Froala Editor (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-22864 and fix it if it is affected.

What it is: CVE-2020-22864 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-22864 in the wild and no public exploit code.

Affected packages and fixed versions:
- froala-editor (npm): affected all versions; fixed in 4.0.11
- froala-editor (npm): affected all versions; fixed in 4.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-22864/ (Markdown: https://insights.sbomify.com/CVE-2020-22864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-22864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-22864
- OSV: https://osv.dev/vulnerability/CVE-2020-22864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-22864/
Summaries are generated and may contain mistakes; the official description above is the record.
