# CVE-2020-2292: Stored XSS vulnerability in Jenkins Release Plugin

> Attackers with release permissions can inject malicious scripts via version strings, leading to stored XSS and potential session hijacking.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vmg8-g8j3-m355

## What is CVE-2020-2292?

CVE-2020-2292 is a medium-severity cross-site scripting vulnerability in Jenkins Release Plugin, published on 8 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Release Plugin 2.10.2 and earlier does not escape the release version in badge tooltip, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Release/Release permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2292?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:release. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:release` | Maven | All versions | 2.11 |
| `org.jenkins-ci.plugins:release` | Maven | All versions | 2.11 |

Products: Jenkins Release.

## How do I fix CVE-2020-2292?

Upgrade org.jenkins-ci.plugins:release to 2.11 or later.

## Is CVE-2020-2292 being exploited?

There is no known exploitation of CVE-2020-2292 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Release Plugin

- [CVE-2018-1000013](https://insights.sbomify.com/CVE-2018-1000013/): CSRF vulnerability in Jenkins Release plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2292 and fix it if it is affected.

What it is: CVE-2020-2292 is a medium-severity cross-site scripting vulnerability in Jenkins Release Plugin, published on 8 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2292 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:release (Maven): affected all versions; fixed in 2.11
- org.jenkins-ci.plugins:release (Maven): affected all versions; fixed in 2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2292/ (Markdown: https://insights.sbomify.com/CVE-2020-2292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2292
- OSV: https://osv.dev/vulnerability/CVE-2020-2292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2292/
Summaries are generated and may contain mistakes; the official description above is the record.
