# CVE-2020-2300: Improper Authentication (empty password) in Jenkins Active Directory Plugin

> Attackers can log in as any user if the Active Directory server allows empty passwords, bypassing authentication in Jenkins.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8wcw-cw2f-h4g2

## What is CVE-2020-2300?

CVE-2020-2300 is a critical authentication bypass vulnerability in Jenkins Active Directory Plugin, published on 4 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Active Directory Plugin 2.19 and earlier does not prohibit the use of an empty password in Windows/ADSI mode, which allows attackers to log in to Jenkins as any user depending on the configuration of the Active Directory server.

## Which versions are affected by CVE-2020-2300?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:active-directory. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:active-directory` | Maven | All versions | 2.16.1 |
| `org.jenkins-ci.plugins:active-directory` | Maven | All versions | 2.16.1 |
| `org.jenkins-ci.plugins:active-directory` | Maven | From 2.17 | 2.20 |
| `org.jenkins-ci.plugins:active-directory` | Maven | From 2.17 | 2.20 |

Products: Jenkins Active Directory.

## How do I fix CVE-2020-2300?

Upgrade org.jenkins-ci.plugins:active-directory to a fixed version for your release line: 2.16.1 or 2.20.

## Is CVE-2020-2300 being exploited?

There is no known exploitation of CVE-2020-2300 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Active Directory Plugin

- [CVE-2020-2299](https://insights.sbomify.com/CVE-2020-2299/): Improper Authentication in Jenkins Active Directory Plugin (critical 9.8)
- [CVE-2020-2301](https://insights.sbomify.com/CVE-2020-2301/): Authentication cache in Active Directory Jenkins Plugin allows logging in with any password (critical 9.8)
- [CVE-2017-2649](https://insights.sbomify.com/CVE-2017-2649/): Jenkins Active Directory Plugin did not verify certificate of AD server (high 8.1)
- [CVE-2019-1003009](https://insights.sbomify.com/CVE-2019-1003009/): Jenkins Active Directory Plugin Improper certificate validation with StartTLS (high 7.4)
- [CVE-2026-48918](https://insights.sbomify.com/CVE-2026-48918/): Jenkins Active Directory Plugin follows LDAP referrals by default (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2300 and fix it if it is affected.

What it is: CVE-2020-2300 is a critical authentication bypass vulnerability in Jenkins Active Directory Plugin, published on 4 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2300 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:active-directory (Maven): affected all versions; fixed in 2.16.1
- org.jenkins-ci.plugins:active-directory (Maven): affected all versions; fixed in 2.16.1
- org.jenkins-ci.plugins:active-directory (Maven): affected from 2.17; fixed in 2.20
- org.jenkins-ci.plugins:active-directory (Maven): affected from 2.17; fixed in 2.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2300/ (Markdown: https://insights.sbomify.com/CVE-2020-2300/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2300
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2300
- OSV: https://osv.dev/vulnerability/CVE-2020-2300

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2300/
Summaries are generated and may contain mistakes; the official description above is the record.
