{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:subversion. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2304 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:subversion to 2.13.2 or later.","what":"CVE-2020-2304 is a medium-severity vulnerability in Jenkins Subversion Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2304 and fix it if it is affected.\n\nWhat it is: CVE-2020-2304 is a medium-severity vulnerability in Jenkins Subversion Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2304 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.13.2\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.13.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2304/ (Markdown: https://insights.sbomify.com/CVE-2020-2304/index.md)","id":"CVE-2020-2304","markdown":"https://insights.sbomify.com/CVE-2020-2304/index.md","name":"CVE-2020-2304","record":{"aliases":["GHSA-vp5f-8jgw-j53c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Subversion Plugin","requires_auth":"low_privilege","summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins Subversion Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"subversion","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[],"description":"Jenkins Subversion Plugin 2.13.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins Subversion Plugin","id":"CVE-2020-2304","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"XXE vulnerability in Jenkins Mercurial Plugin","id":"CVE-2020-2305"},"packages":[{"ecosystem":"Maven","fixed":["2.13.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":null,"source":"GHSA-vp5f-8jgw-j53c"},{"ecosystem":"Maven","fixed":["2.13.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":"pkg:maven/org.jenkins-ci.plugins/subversion","source":"GHSA-vp5f-8jgw-j53c"}],"prev":{"headline":"CSRF vulnerability in Jenkins Active Directory Plugin","id":"CVE-2020-2303"},"products":["Jenkins Subversion Plugin"],"published":"2020-11-04","related":[{"cvss_score":7.5,"headline":"Path traversal vulnerability in Jenkins Subversion Plugin allows reading arbitrary files","id":"CVE-2021-21698","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":6.5,"headline":"Jenkins Subversion Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2017-1000085","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":5.4,"headline":"Subversion Plugin stored XSS vulnerability","id":"CVE-2020-2111","kev_date_added":null,"published":"2020-02-12"},{"cvss_score":5.3,"headline":"Jenkins Subversion Plugin Incorrect Authorization vulnerability","id":"CVE-2018-1000111","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins Subversion Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2020-2304/"}