CVE-2020-2306 Missing Authorization in Jenkins Mercurial Plugin
Attackers with read permissions can view configured Mercurial installation names due to missing permission checks in the Jenkins Mercurial Plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-2306?
CVE-2020-2306 is a medium-severity missing authorization vulnerability in Jenkins Mercurial Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A missing permission check in Jenkins Mercurial Plugin 2.11 and earlier allows attackers with Overall/Read permission to obtain a list of names of configured Mercurial installations.
Which versions are affected by CVE-2020-2306?
8 open source packages ship an affected version, including org.jenkins-ci.plugins:mercurial. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.plugins:mercurial Maven | All versions | 2.8.1 |
org.jenkins-ci.plugins:mercurial Maven | All versions | 2.8.1 |
org.jenkins-ci.plugins:mercurial Maven | From 2.10 | 2.10.1 |
org.jenkins-ci.plugins:mercurial Maven | From 2.10 | 2.10.1 |
org.jenkins-ci.plugins:mercurial Maven | From 2.11 | 2.12 |
org.jenkins-ci.plugins:mercurial Maven | From 2.11 | 2.12 |
2 more packages
org.jenkins-ci.plugins:mercurial Maven | From 2.9 | 2.9.1 |
org.jenkins-ci.plugins:mercurial Maven | From 2.9 | 2.9.1 |
Products include Jenkins Mercurial.
How do I fix CVE-2020-2306?
Upgrade org.jenkins-ci.plugins:mercurial to a fixed version for your release line: 2.8.1, 2.10.1, 2.12 or 2.9.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-2306 being exploited?
There is no known exploitation of CVE-2020-2306 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Mercurial Plugin
Sources
Also known as GHSA-vrrc-3wwh-frgx.