# CVE-2020-2306: Missing Authorization in Jenkins Mercurial Plugin

> Attackers with read permissions can view configured Mercurial installation names due to missing permission checks in the Jenkins Mercurial Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vrrc-3wwh-frgx

## What is CVE-2020-2306?

CVE-2020-2306 is a medium-severity missing authorization vulnerability in Jenkins Mercurial Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Mercurial Plugin 2.11 and earlier allows attackers with Overall/Read permission to obtain a list of names of configured Mercurial installations.

## Which versions are affected by CVE-2020-2306?

8 open source packages ship an affected version, including org.jenkins-ci.plugins:mercurial. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:mercurial` | Maven | All versions | 2.8.1 |
| `org.jenkins-ci.plugins:mercurial` | Maven | All versions | 2.8.1 |
| `org.jenkins-ci.plugins:mercurial` | Maven | From 2.10 | 2.10.1 |
| `org.jenkins-ci.plugins:mercurial` | Maven | From 2.10 | 2.10.1 |
| `org.jenkins-ci.plugins:mercurial` | Maven | From 2.11 | 2.12 |
| `org.jenkins-ci.plugins:mercurial` | Maven | From 2.11 | 2.12 |
| `org.jenkins-ci.plugins:mercurial` | Maven | From 2.9 | 2.9.1 |
| `org.jenkins-ci.plugins:mercurial` | Maven | From 2.9 | 2.9.1 |

Products: Jenkins Mercurial.

## How do I fix CVE-2020-2306?

Upgrade org.jenkins-ci.plugins:mercurial to a fixed version for your release line: 2.8.1, 2.10.1, 2.12 or 2.9.1.

## Is CVE-2020-2306 being exploited?

There is no known exploitation of CVE-2020-2306 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Mercurial Plugin

- [CVE-2022-30948](https://insights.sbomify.com/CVE-2022-30948/): Path traversal in Jenkins Mercurial Plugin (high 7.5)
- [CVE-2020-2305](https://insights.sbomify.com/CVE-2020-2305/): XXE vulnerability in Jenkins Mercurial Plugin (medium 6.5)
- [CVE-2022-43410](https://insights.sbomify.com/CVE-2022-43410/): Webhook endpoint discloses job names to unauthorized users in Jenkins Mercurial Plugin (medium 5.3)
- [CVE-2018-1000112](https://insights.sbomify.com/CVE-2018-1000112/): Incorrect Authorization in Jenkins Mercurial Plugin (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2306 and fix it if it is affected.

What it is: CVE-2020-2306 is a medium-severity missing authorization vulnerability in Jenkins Mercurial Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2306 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:mercurial (Maven): affected all versions; fixed in 2.8.1
- org.jenkins-ci.plugins:mercurial (Maven): affected all versions; fixed in 2.8.1
- org.jenkins-ci.plugins:mercurial (Maven): affected from 2.10; fixed in 2.10.1
- org.jenkins-ci.plugins:mercurial (Maven): affected from 2.10; fixed in 2.10.1
- org.jenkins-ci.plugins:mercurial (Maven): affected from 2.11; fixed in 2.12
- org.jenkins-ci.plugins:mercurial (Maven): affected from 2.11; fixed in 2.12
- org.jenkins-ci.plugins:mercurial (Maven): affected from 2.9; fixed in 2.9.1
- org.jenkins-ci.plugins:mercurial (Maven): affected from 2.9; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2306/ (Markdown: https://insights.sbomify.com/CVE-2020-2306/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2306
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2306
- OSV: https://osv.dev/vulnerability/CVE-2020-2306

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2306/
Summaries are generated and may contain mistakes; the official description above is the record.
