CVE-2020-2307 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins Kubernetes Plugin

Medium 4.3 Published Updated

Low-privilege users can access sensitive Jenkins controller environment variables via the Kubernetes Plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-2307?

CVE-2020-2307 is a medium-severity vulnerability in Jenkins Kubernetes Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins Kubernetes Plugin 1.27.3 and earlier allows low-privilege users to access possibly sensitive Jenkins controller environment variables.

Which versions are affected by CVE-2020-2307?

8 open source packages ship an affected version, including org.csanchez.jenkins.plugins:kubernetes. It affects 1 product.

PackageAffectedFixed in
org.csanchez.jenkins.plugins:kubernetes MavenAll versions1.21.6
org.csanchez.jenkins.plugins:kubernetes MavenAll versions1.21.6
org.csanchez.jenkins.plugins:kubernetes MavenFrom 1.22.01.25.4.1
org.csanchez.jenkins.plugins:kubernetes MavenFrom 1.22.01.25.4.1
org.csanchez.jenkins.plugins:kubernetes MavenFrom 1.26.01.26.5
org.csanchez.jenkins.plugins:kubernetes MavenFrom 1.26.01.26.5
2 more packages
org.csanchez.jenkins.plugins:kubernetes MavenFrom 1.27.01.27.4
org.csanchez.jenkins.plugins:kubernetes MavenFrom 1.27.01.27.4

Products include Jenkins Kubernetes.

How do I fix CVE-2020-2307?

Upgrade org.csanchez.jenkins.plugins:kubernetes to a fixed version for your release line: 1.21.6, 1.25.4.1, 1.26.5 or 1.27.4.

Is CVE-2020-2307 being exploited?

There is no known exploitation of CVE-2020-2307 in the wild and no public exploit code.

Sources

Also known as GHSA-fh5w-p2j4-4p8x.

Is CVE-2020-2307 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free