{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:ansible. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2310 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:ansible to 1.1 or later.","what":"CVE-2020-2310 is a medium-severity vulnerability in Jenkins Ansible Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2310 and fix it if it is affected.\n\nWhat it is: CVE-2020-2310 is a medium-severity vulnerability in Jenkins Ansible Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2310 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:ansible (Maven): affected all versions; fixed in 1.1\n- org.jenkins-ci.plugins:ansible (Maven): affected all versions; fixed in 1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2310/ (Markdown: https://insights.sbomify.com/CVE-2020-2310/index.md)","id":"CVE-2020-2310","markdown":"https://insights.sbomify.com/CVE-2020-2310/index.md","name":"CVE-2020-2310","record":{"aliases":["GHSA-6xqj-wvgp-rqp8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Ansible Plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can enumerate stored credential IDs due to missing permission checks in the Jenkins Ansible Plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"ansible","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[],"description":"Missing permission checks in Jenkins Ansible Plugin 1.0 and earlier allow attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing permission checks in Jenkins Ansible Plugin allow enumerating credentials IDs","id":"CVE-2020-2310","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Missing permission check in Jenkins AWS Global Configuration Plugin allows replacing plugin configuration","id":"CVE-2020-2311"},"packages":[{"ecosystem":"Maven","fixed":["1.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ansible","purl":null,"source":"GHSA-6xqj-wvgp-rqp8"},{"ecosystem":"Maven","fixed":["1.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ansible","purl":"pkg:maven/org.jenkins-ci.plugins/ansible","source":"GHSA-6xqj-wvgp-rqp8"}],"prev":{"headline":"Missing authorization in Jenkins Kubernetes Plugin","id":"CVE-2020-2309"},"products":["Jenkins Ansible Plugin"],"published":"2020-11-04","related":[{"cvss_score":5.6,"headline":"Jenkins Ansible Plugin man in the middle vulnerability","id":"CVE-2018-1000149","kev_date_added":null,"published":"2018-04-05"},{"cvss_score":5.3,"headline":"Jenkins Ansible Plugin job configuration form does not mask variables","id":"CVE-2023-32983","kev_date_added":null,"published":"2023-05-16"},{"cvss_score":4.3,"headline":"Jenkins Ansible Plugin stores and displays secrets in plain text","id":"CVE-2023-32982","kev_date_added":null,"published":"2023-05-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can enumerate stored credential IDs due to missing permission checks in the Jenkins Ansible Plugin.","url":"https://insights.sbomify.com/CVE-2020-2310/"}