# CVE-2020-2310: Missing permission checks in Jenkins Ansible Plugin allow enumerating credentials IDs

> Attackers with read permissions can enumerate stored credential IDs due to missing permission checks in the Jenkins Ansible Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6xqj-wvgp-rqp8

## What is CVE-2020-2310?

CVE-2020-2310 is a medium-severity vulnerability in Jenkins Ansible Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Missing permission checks in Jenkins Ansible Plugin 1.0 and earlier allow attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.

## Which versions are affected by CVE-2020-2310?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ansible` | Maven | All versions | 1.1 |
| `org.jenkins-ci.plugins:ansible` | Maven | All versions | 1.1 |

Products: Jenkins Ansible.

## How do I fix CVE-2020-2310?

Upgrade org.jenkins-ci.plugins:ansible to 1.1 or later.

## Is CVE-2020-2310 being exploited?

There is no known exploitation of CVE-2020-2310 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Ansible Plugin

- [CVE-2018-1000149](https://insights.sbomify.com/CVE-2018-1000149/): Jenkins Ansible Plugin man in the middle vulnerability (medium 5.6)
- [CVE-2023-32983](https://insights.sbomify.com/CVE-2023-32983/): Jenkins Ansible Plugin job configuration form does not mask variables (medium 5.3)
- [CVE-2023-32982](https://insights.sbomify.com/CVE-2023-32982/): Jenkins Ansible Plugin stores and displays secrets in plain text (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2310 and fix it if it is affected.

What it is: CVE-2020-2310 is a medium-severity vulnerability in Jenkins Ansible Plugin, published on 4 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2310 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ansible (Maven): affected all versions; fixed in 1.1
- org.jenkins-ci.plugins:ansible (Maven): affected all versions; fixed in 1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2310/ (Markdown: https://insights.sbomify.com/CVE-2020-2310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2310
- OSV: https://osv.dev/vulnerability/CVE-2020-2310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2310/
Summaries are generated and may contain mistakes; the official description above is the record.
