{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:cvs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2324 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:cvs to 2.17 or later.","what":"CVE-2020-2324 is a high-severity vulnerability in Jenkins CVS Plugin, published on 3 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2324 and fix it if it is affected.\n\nWhat it is: CVE-2020-2324 is a high-severity vulnerability in Jenkins CVS Plugin, published on 3 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2324 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:cvs (Maven): affected all versions; fixed in 2.17\n- org.jenkins-ci.plugins:cvs (Maven): affected all versions; fixed in 2.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2324/ (Markdown: https://insights.sbomify.com/CVE-2020-2324/index.md)","id":"CVE-2020-2324","markdown":"https://insights.sbomify.com/CVE-2020-2324/index.md","name":"CVE-2020-2324","record":{"aliases":["GHSA-g9hg-x9c9-7xgr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CVS Plugin","requires_auth":"none","summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins CVS Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"cvs","vendor":"jenkins"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins CVS Plugin 2.16 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins CVS Plugin","id":"CVE-2020-2324","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Command injection in QTS","id":"CVE-2020-2490"},"packages":[{"ecosystem":"Maven","fixed":["2.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cvs","purl":null,"source":"GHSA-g9hg-x9c9-7xgr"},{"ecosystem":"Maven","fixed":["2.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cvs","purl":"pkg:maven/org.jenkins-ci.plugins/cvs","source":"GHSA-g9hg-x9c9-7xgr"}],"prev":{"headline":"Missing permission checks in Jenkins Chaos Monkey Plugin","id":"CVE-2020-2323"},"products":["Jenkins CVS Plugin"],"published":"2020-12-03","related":[{"cvss_score":5.4,"headline":"Stored XSS in Jenkins CVS Plugin","id":"CVE-2022-29037","kev_date_added":null,"published":"2022-04-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins CVS Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2020-2324/"}