{"answers":{"affected":"3 open source packages ship an affected version, including leo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-23478 in the wild and no public exploit code.","fix":"Upgrade leo to 6.3 or later.","what":"CVE-2020-23478 is a high-severity denial of service vulnerability in n/a, published on 22 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-23478 and fix it if it is affected.\n\nWhat it is: CVE-2020-23478 is a high-severity denial of service vulnerability in n/a, published on 22 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-23478 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- leo (PyPI): affected all versions; fixed in 6.3\n- leo (PyPI): affected all versions; fixed in 6.3\n- leo (PyPI): affected all versions; fixed in 6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-23478/ (Markdown: https://insights.sbomify.com/CVE-2020-23478/index.md)","id":"CVE-2020-23478","markdown":"https://insights.sbomify.com/CVE-2020-23478/index.md","name":"CVE-2020-23478","record":{"aliases":["GHSA-x38q-xg2h-rxgx","PYSEC-2021-338"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Leo Editor","requires_auth":"none","summary":"Attackers can cause a denial of service in Leo Editor via a regular expression denial of service vulnerability in the Dart importer plugin.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"leo","vendor":"leoeditor"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-697","name":"Incorrect Comparison"}],"description":"Leo Editor v6.2.1 was discovered to contain a regular expression denial of service (ReDoS) vulnerability in the component plugins/importers/dart.py.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in Leo Editor","id":"CVE-2020-23478","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-23481"},"packages":[{"ecosystem":"PyPI","fixed":["6.3"],"introduced":["0"],"last_affected":[],"package":"leo","purl":null,"source":"GHSA-x38q-xg2h-rxgx"},{"ecosystem":"PyPI","fixed":["6.3"],"introduced":["0"],"last_affected":[],"package":"leo","purl":"pkg:pypi/leo","source":"GHSA-x38q-xg2h-rxgx"},{"ecosystem":"PyPI","fixed":["6.3"],"introduced":["0"],"last_affected":[],"package":"leo","purl":"pkg:pypi/leo","source":"PYSEC-2021-338"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2020-23469"},"products":["n/a"],"published":"2021-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can cause a denial of service in Leo Editor via a regular expression denial of service vulnerability in the Dart importer plugin.","url":"https://insights.sbomify.com/CVE-2020-23478/"}